> ## Documentation Index
> Fetch the complete documentation index at: https://docs.ntop.com/llms.txt
> Use this file to discover all available pages before exploring further.

# My Account Welcome email never arrived

## Issue:

I received a license deployment email but have not received an account activation email

My Welcome email never arrived and I'm unable to create an account.

Can you resend my Welcome email?

I can't activate my account without the Welcome email.

## Applies to:

* nTop Licensing

## Cause:

This issue may occur if:

* * Spam filters caught the message
    * Your inbox is full
    * The email address is incorrect
    * Your VPN is blocking the email

Occasionally, an organization's security practices can block our automated messages.

Extending, renewing, or changing a current nTop account does not automatically trigger an email.

## Solution:

Take the following troubleshooting steps:

1. 1. Check your spam and bulk folder for messages from [no-reply@ntop.com](mailto:no-reply@ntopology.com).
   2. Add [no-reply@ntop.com](mailto:no-reply@ntopology.com) and [engineering@ntop.com](mailto:engineering@ntop.com) to your contacts to receive emails about licensing, product updates, and newsletters from us.
   3. Browse to [app.ntop.com](https://app.ntopology.com/) and click Forgot Password. This step generates a new email that allows you to log in and create an account.
   4. Talk to your IT department about the VPN possibly blocking the email.

If the issue continues after these steps, please contact Support to verify that the system uses the correct email. We may need to talk with your IT department to get it fixed. As a workaround, users can provide nTop with an alternate email.

## Keywords:

*account license email trial welcome missing spam blocked activation emails resend*
